
CYCLADES IST-2000-25456
An Open Collaborative Virtual Archive Environment

The Cyclades Graphical User Interface

Addendum to D4.2.1

Date: July 18, 2003

Name of Responsible: Gudrun Fischer

University of Duisburg-Essen
Institute of Informatics and Interactive Systems, Faculty 5

47048 Duisburg
Germany

E-Mail: Gudrun.Fischer@uni-duisburg.de

Contributors

CNR-ISTI: Umberto Straccia, Leonardo Candela
University of Duisburg-Essen: Gudrun Fischer

FORTH: Nick Papadopoulos
FhG-FIT: Tom Gross, Thomas Kreifelts, Wido Wirsam, Silvio Caizzi

Abstract: This is a short addendum to D4.2.1, describing the updated graphical user interface
of the Cyclades system.



Contents

1 Introduction 4

2 Mediator Service 5

2.1 Registration and login . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

2.2 GUI integration and the services Menu . . . . . . . . . . . . . . . . . . . . . . . . . 5

2.3 User management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

3 Collaborative Work Service 7

3.1 The folder listing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

3.2 The instant access navigation buttons . . . . . . . . . . . . . . . . . . . . . . . . . 8

3.3 The menu bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

3.4 The communities listing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

3.5 The collections and services listing . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

3.6 The recommendations folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

3.7 The multi-action buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

3.8 The action menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

3.9 Context sensitive help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

4 Search and Browse Service 15

4.1 The collection list . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

4.2 Conditions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

4.3 Attribute values dialogue . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

4.4 Main menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

4.5 Collection selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

4.6 Schema selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

4.7 Query selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

4.8 Result list . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

5 Access Service 20

5.1 The archive list . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

5.2 The archive information dialogue . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

6 Collection Service 22

2



The Cyclades Graphical User Interface(Addendum to D4.2.1) 3

6.1 The menu bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

6.2 The action menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

6.3 The collections hierarchy area . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

6.4 The collection data area . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

7 Other Services 25

7.1 Filtering and Recommendation Service . . . . . . . . . . . . . . . . . . . . . . . . . 25

7.2 Rating Management Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25



Chapter 1

Introduction

This document describes the graphical user interface of the Cyclades system. The individual
components of the user interface have been presented in D4.2.1, the System Testing Report. Since
the delivery of that report, some details have changed in some parts of the user interface. Therefore,
the Cyclades consortium has compiled this unofficial addendum to D4.2.1 in order to provide an
up-to-date description of the user interface at the end of the project.

The structure follows roughly the path a user could take through the system. First, she will see the
Cyclades login page provided by the Mediator Service. After logging in, she will be presented
with a page composed of two parts: a services menu bar provided by the Mediator Service, and a
view of her own home folder provided by the Collaborative Work Service. The user interfaces of
the other services, if available, can be accessed via the services menu. Those user interfaces are
presented each in its own window.

Since the delivery of D4.2.1, details have changed in the graphical user interfaces of the following
services:

• Collaborative Work Service, chapter 3

• Search and Browse Service, chapter 4

• Access Service, chapter 5
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Chapter 2

Mediator Service

The Mediator Service (MS) integrates and enables the various services of Cyclades to communi-
cate with each other. It stores information about the services and the registered users in Cyclades.
The MS is responsible for services’ ”registration” to the system. All services in Cyclades refer
to the MS in order to get information about other services.

The MS partly handles the registration of the users in Cyclades and fully handles the loggin
of the users to the system, via the graphical user interface. Also the MS, in interaction with the
Collaborative Work Service, is involved in the cases of user’s invitation.

Thus, the MS supports:

• Inter-System Communication,

• User Registration and Login,

• Service Registration.

2.1 Registration and login

Of these tasks, only the first two are relevant to the graphical user interface. The MS provides the
initial Cyclades page where the user can register or login into Cyclades.

2.2 GUI integration and the services Menu

After succesfull login, the user is presented with an interface where both her home folder (CWS
GUI, chapter 3) and a button menu for accessing other Cyclades services are shown. The user
can either navigate through her folders or choose to activate a service. If she chooses to activate
another service, then she is presented with that service’s user interface.

2.3 User management

Among the buttons that the user is presented with, in the services menu in MS GUI, there is a
button for administration purposes. If the user chooses to press that button then a form asking
for administration password will be shown. There the user in order to continue must fill in the
administrator’s password or, in the case that she has been granted with the administration privilege,
she must fill in her name and her pasword. In the MS administration area someone can see all the
registered users in Cyclades and can apply various actions on them.

5
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The actions an administrator can apply onto the users (for the moment) are:

• remove a user

• delete a user

• check whether a user has administrator’s privileges or not

• set the administrator privilege to a user

• un-set the administrator privilege to a user

(Of course the set of actions can be extended.)



Chapter 3

Collaborative Work Service

The Collaborative Work Service (CWS) stores the private, community and project folders of the
registered Cyclades users along with their contents which may be other folders, metadata records,
queries and discussion forums. Project folders may contain also other material. The service
supports

• folder and contents management,

• collaboration between users by way of folder sharing in communities and projects, discussion
forums and mutual awareness,

• recommendations management.

The graphical user interface of the CWS presents the folders to which a registered user of the
Cyclades system has access and allows for navigation among these folders and for adding, moving,
deleting, reading or editing artifacts within those folders. The user interface shows the contents
of one folder at a time in a folder listing. The functionality may be invoked by using menus and
buttons that are part of a folder listing.

3.1 The folder listing

The CWS user interface presents the contents of a folder in a tabular representation with a header
containing menus, navigation buttons and action shortcut buttons. As an example figure 3.1
shows a folder listing with an open File menu for creating new objects in the folder.

Several classes of artifacts can be created and shared in a folder: various kinds of folders (private,
project, community), discussion forums containing notes, and annotations of artifacts which also
consist of notes. In project folders, additional kinds of artifacts may be created and shared:
documents and URLs. Records and queries are not created via user operations, but transferred
from the Search and Browse Service; they may also be shared in folders.

Each artifact contained in a folder is represented by an entry in the folder listing. An entry
consists of an information button, a checkbox (that a user has to “tick” to select the artifact for
some multi-action), the name of the artifact, some icons, additional data and an action menu
button.

Most prominent in each entry is the name of the artifact. Obviously, a user should choose names
describing the content or purpose of each individual artifact. The URL to the original e-print
document to which the respective meta-data record refers is automatically included in the artefact
name. This allows the user to easily access the original e-print document without having the first
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go into the source of the meta-data record (cf. 3.2). The icon immediately left of the artifact
name denotes the artifact type.

The icon immediately left of the artifact name denotes the artifact type. To the right of the artifact
name the CWS user interface displays:

• Zero, one or more of the following icons:

– shared icon indicates that a folder is shared;

– lock icon indicates that someone has set a lock for this artifact;

– note icon indicates that a note has been added to the artifact;

– rate icon indicates that the document has been rated by one or more folder members;

• the user name of its owner;

• date and time of the most recent modification;

• zero, one or more icons indicating that some of the following events have occurred:

– new icon indicates a new artifact;

– change icon indicates changes to the artifact;

– read icon indicates that someone has read the artifact;

– modification icon indicates recent modifications in a sub-artifact;

• a menu button showing the actions involving the artifact.

Note that different actions are possible for different types of artifacts. Depending on the individual
access rights, the number and type of actions permitted may vary.

Most icons in an artifact entry are “clickable”, i. e. one gets more information on a community, a
lock, a note, a rating etc. when one clicks on it.

3.2 The instant access navigation buttons

The upper right hand corner of the interface provides an icon bar showing buttons applicable to
instantly access certain artifacts.

• home folder icon represents a user’s home folder.

• communities icon represents a the existing communities.

• clipboard icon recpresents a user’s clipboard, which serves as an intermediate store.

• waste icon represents a user’s waste, which helps to prevent unauthorized or unintentional
deletion of artifacts: In the CWS, an artifact can be irrevocably destroyed only from the
waste-basket of its owner.

• address book icon represents a user’s address book, to be used primarily to invite new members
to the user’s folder.

• search & browse icon represents the access to the Search & Browse Service.
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3.3 The menu bar

At the upper left hand corner of the interface there is a menu bar with five menus and action
shortcut buttons for the most frequent actions.

New artifacts are added to the current folder by selecting one of the File menu options:

File → New plus a sub-option from the list Discussion, Private Folder, Community Folder, Project
Folder in order to create an artifact of the specified type directly on the CWS server. For project
folders, also documents, and URLs may be created. Examples are:

• Select File → New → Private Folder in order to create a private folder within the current
private or home folder.

• Select File → New → Community Folder in order to create a community folder within the
current community or home folder.

• Select File → New → Project Folder in order to create a project folder within the current
project or home folder.

• Select File → New → Document to upload a file from the user’s local computer system to
the current project folder.

If the user wants to create a new private, community or project folder, the CWS user interface asks
for name, description, collections to be associated to that folder; finally the user is asked to specify
whether recommendations are requested for records, users, collections, or communities, (i. e. tick
the appropriate box). For communities one has to also specify in the creation dialogue whether
the community is open to be joined by external users.

When a new document is identified to be uploaded to the CWS server, the user is asked via
an additional dialogue to specify the document’s local URL, name, description, MIME type and
encoding.

If the user wants to rate the new artifact, she may choose one of the following options: no (for no
rating available), very poor, poor, fair, good, or excellent, by ticking the respective radio button.

The Edit menu is used to transfer existing artifacts to/from from the clipboard by the following
procedure. Select the Paste option in the Edit menu to add artifacts that arrived at the Clipboard
from somewhere in the user’s folders as a result of the most recent Copy or Cut action to the
current Folder.

Via the Options menu, the user may edit Preferences, personal user Details, user Communication
specifics, or user Default Events.

To navigate among the particular entities one can also use the GoTo menu.

• Select GoTo → Home to get to the user’s home folder.

• Select GoTo → Communities to get to the existing communities.

• Select GoTo → Clipboard to get to the user’s clipboard.

• Select GoTo → Waste to get to the user’s waste.

• Select GoTo → Address Book to get to the user’s address book.

• Select GoTo → Search & Browse to get to the Search & Browse Service.

• Select GoTo → User Info to receive the specifics of the user information stored in the system.

System administrators may access the existing collections and services via the following options of
the GoTo menu.
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• Select GoTo → Collections

• Select GoTo → Services

3.4 The communities listing

The communities listing shows the existing communities in the style of a folder listing. The
communities are represented by their root folders. Community objects in the communities listing
allow the following functions via the action menus (cf. below):

• Join Community to join the community, if it is open to subscription,

• Mail Community Mgrs to send an electronic letter to the manager(s) of a particular commu-
nity (e. g. to get invited to a community).

3.5 The collections and services listing

The collections and services listings are intended mainly for administrators and show the existing
collections and services in the style of a folder listing.

The collections folder allows the function

• Update Collections to update the list of collections from the Collection Service

via the action menu (cf. below). The collection objects have no specific functions other than Info.

The service objects in the services listing indicate the status of the service via the service icon and
allow the functions

• Ping to test the availability of the service,

• Process Queue to process queued calls for this service (administrators only)

via the action menu. The services folder allows the function

• Update Services to update the list of services from the Mediator Service

also via its action menu.

3.6 The recommendations folder

Every folder may have up to one recommendations folder that contains the recommendations of
records, collections, users or communities intended for this folder. The title of the recommenda-
tions folder is always Recommendations, it may not be moved. A recommendations folder may
only contain recommended objects inserted by the system when received from the Filtering and
Recommendation Service. Recommended objects allow the following functions via the action menu
(cf. below):

• recommended records may be moved or copied to other folders,

• recommended collections may be associated to the containing folder,



The Cyclades Graphical User Interface(Addendum to D4.2.1) 11

• recommended users may be invited to the containing folder (managers only) or may be
contacted by electronic mail,

• recommended communities may be joined if open for subscription or their managers may be
contacted by electronic mail.

Recommendations may of course also be deleted. All these functions are invoked via the action
menu of the respective entry.

3.7 The multi-action buttons

Preceding the list of artifacts, the CWS user interface provides a number of buttons for actions to
be applied to several selected artifacts.

In general, an artifact is selected by marking the checkbox to the left of its name. The Select all
and Select none buttons are shortcuts for selecting or de-selecting all artifacts within the current
folder.

Hitting, e. g., the copy button invokes copying, and hitting the cut button triggers transfer of the
selected artifacts to the user’s clipboard; hitting the delete button invokes transfer of the selected
artifacts to the waste. Certain buttons such as send and rate trigger actions that can be applied
only to artifacts of specific types.

Note that artifacts transferred from a folder to the clipboard or to the waste are no longer visible
to the members of the folder.

3.8 The action menus

At the right end of the entry containing the artifact name in the folder listing, the CWS user
interface provides for every entry an action menu for operations to be applied only to that particular
artifact. Here one gets all the actions that are applicable to the artifact, including generic ones
like Open, Catch up, History, Info, or actions that depend on the nature of the artifact, e. g. Rate,
Attach note for records or Add Collections, Remove Collections for Cyclades folders.

Here in the single action menu the actions more specific to CWS are to be found that do not appear
in the menu bar or the multi-actions:

• Add Collections to associate additional collections to a Cyclades folder,

• Remove Collections to remove collections from the set of collections associated to a Cyclades
folder,

• Edit Reco Prefs to modify the preferences for the recommendations sought for,

• Allow Subscription to allow subscription to a community,

• Deny Subscription to refuse subscription to a community,

• Update Folder Profile to request an immediate update of the folder profile in the Filtering
and Recommendation Service,

• Join Community to join the selected community,

• Mail Community Mgrs to send an electronic letter to the manager(s) of a particular commu-
nity (e. g. to get permission to join a community).
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The configuration of the Action menu depends on the type of artifact—for example, different
actions are appropriate for a URL artifact, a folder or a document.

What actions are applicable to which artifacts? Access right management in the CWS is based on
roles, whereby a role defines the set of artifacts and actions a user may apply for a specific task.
As a consequence, the CWS will not display the single action menu entries for actions that a user
may not perform on the specific artifact w. r. t. to the role assigned to the particular user. On
the other hand, one may invite, for example, new community members assigning roles to them.
Moreover, roles define access profiles which can be attached to any artifact in the CWS. A set of
pre-defined roles serves as a starting point: manager, owner (originally the creator; also accountable
for the disk space used), member and restricted member (read-only access). Role assignments are
inherited along the folder hierarchy and can be modified at any time. In the pre-defined role
definition, member management is reserved to managers.

3.9 Context sensitive help

The context sensitive help feature provides assistance to navigate the system. In a number of
application environments one may click the question mark button to get an explanation of the
action to be launched.
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Figure 3.1: CWS user interface
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Figure 3.2: CWS user interface



Chapter 4

Search and Browse Service

The Search and Browse Service (SBS) provides the search and browse functionality of the Cy-
clades system. The user can select a set of collections to search, choose between the schemas
available for these collections, and formulate query conditions which may be mandatory (the con-
dition must be fulfilled), optional (the condition may be fulfilled), or negative (the condition must
not be fulfilled).

The first page that is shown when the Search and Browse GUI is called is the query formulation
dialogue (figure 4.1).

Figure 4.1: SB Query Formulation

A query consists of a (possibly empty) list of collections to be searched, and a list of conditions.
This is reflected by the two list areas in the query formulation dialogue.

15
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4.1 The collection list

This list in the upper part of the query formulation dialogue contains those collections that the
user wants to be searched in the current query. If the list does not contain any specific collection,
a hint is displayed that all collections in the system will be searched.

In the menu bar above the collection list, the user can select all collections, or none. Individial
collections can be selected via the checkbox beside the collection name. The user can then delete
the selected collections from the query by pressing the Delete button in this bar.

4.2 Conditions

The list of conditions is displayed in the lower part of the query formulation dialogue. Each
condition consists of an optional weight (which can be ”+”, ”-”, or a positive number between 1
and 1000), an attribute (according to the current metadata schema), a predicate, and a comparison
value.

The condition list always contains at least three conditions. Incomplete conditions, i.e. conditions
where the field or predicate have not been selected, are ignored internally when the query is
processed by the SBS.

In the menu bar above the list of conditions, the user can select all, or none, for further actions.
Each condition can also be selected or deselected individually via the checkbox on the left. The
Delete button in the menu bar causes all selected conditions to be removed from the query, the
Copy button duplicates each selected condition. Add ignores selections and simply adds an empty
condition to the query.

On the right hand side of each query condition, there is an action link Show values. This will pop
up the attribute values dialogue described in the next section.

4.3 Attribute values dialogue

In this dialogue (figure 4.2), the user can browse terms occuring in the field (attribute) in the
condition for which the dialogue was opened, if any has been selected already. The dialogue
also contains a simple filtering functionality for browsing terms beginning with a certain string of
characters. In this way, the user can determine, for example, all possible terms for the field ”title”,
which start with ”intel”, and then copy a suitable term into the query formulation dialogue.

4.4 Main menu

The main menu bar at the top of the query formulation dialogue contains the following entries:

• Action

• Current query

• Collections

The Action menu contains actions that replace the current query without saving it:

• New query - Forget the current query and start with an empty one

• Get new records for folder - Forget the current query and get new records for the current
folder instead
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Figure 4.2: SB: Browsing attribute values

• Select query from history - Select another query from the session history

• Select query from folder - Select another query from the current folder

The Current query menu contains actions that refer to the current query:

• Submit - Submit the query as is

• Submit personalized - Submit the query and filter the results (calls the Filtering and Recom-
mendation Service)

• Save to folder - Save the current query to the folder

The Collections menu contains actions to add collections to the current query:

• Add from folder - Add collections that are associated to the current folder

• Add from personal set - Add collections from the set of personal collections

• Add from system - Add collections from the set of all collections in the system

• Use all - Clear the list of collections in the current query, thus causing all collections in the
system to be searched

4.5 Collection selection

Each of the first three actions in the Collections menu opens a dialogue with a list of collections.
The user can select all, or none, of those collections via the multi-object menu above the list, or
individual collections via the checkboxes beside each collection name, and then add the selected
collections to the current query by pressing the Add button in the menu bar. This will take the
user back to the query formulation dialogue, augmented by the additional collections.
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4.6 Schema selection

This functionality is still missing from the current Search and Browse GUI. It will be implemented
as a schema selection dialogue later, after the end of the current project.

4.7 Query selection

The query selection dialogue is shown when the user chooses to select a query either from the query
history of the current session, or from the list of queries stored in the current folder. Each query
is displayed with its name, if it has one, else with an automatically generated ID. By clicking on
a query, the user returns to the query formulation dialogue, where the selected query is displayed.

4.8 Result list

A result list (figure 4.3) is shown whenever a query was submitted, or the user requested to look
for new records for the current folder. It consists of a list of records, and a multi-object menu
above the list. Each record is displayed wither with its title, or, if there is no title, with its record
id. A click on a record opens a new window which displays the complete metadata record as it
was harvested from its archive.

On the left-hand side of each record list entry, there is a checkbox for selecting the record. The
user can also select all records, or none, via the multi-object menu. Selected records can be saved
to the current folder by pressing the Save button in the multi-object menu.
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Figure 4.3: SB Result List



Chapter 5

Access Service

The Access Service (AS) harvests and indexes metadata records from open archives and makes
them available for other Cyclades services. For this purpose, it provides

• metadata harvesting and indexing

• persistent storage of metadata records

• management of archive information

For the third of these tasks, the AS provides a graphical user interface. After being called, it
presents in a new window a (possibly empty) list of archive objects owned by the user (figure 5.1).

5.1 The archive list

Each archive object can be selected for multi-object actions. At the moment, the only possible
multi-object action is deletion, however, more actions may be added in the future. Multi-object
actions are available as buttons above the list of archives.

A click on an archive name, or on the Edit link at the right hand side of each entry in the archives
list, will take the user to the archive information dialogue described in the next section.

The Archive menu contains only one option, i. e. Register new, for registering a new archive. After
choosing this option, the user is presented first with an input form for the new archive’s URL, and
then with the archive information dialogue.

5.2 The archive information dialogue

In this dialogue, the registration information about a single archive is presented, and the user can
edit some parts of it.

At the top, some basic, non-editable information is shown:

• The URL of the archive

• The repository ID of the archive, according to its Identify record

• The repository name of the archive, according to its Identify record

• The e-mail address of the archive administrator, according to its Identify record

20
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Figure 5.1: AS Graphical User Interface

In the next three lines, the user can specify mirror sites for the archive. This information is not
used at the current stage of the Cyclades system, being a prototype, but it will be used in the
future to provide access to archives which are not very reliable or offline, but which are mirrored
at other sites.

Finally, the user can also specify languages supported by the archive, and keywords describing the
archive’s content. This information is useful to describe the archive to other users who might want
to use it in their collections.

Still missing from the current AS prototype GUI is the functionality to browse and select schemas
and subschemas (parts of schemas) for harvesting and indexing, from the list of schemas that the
archive supports. This will be included in a future version of the Access Service, after the end of
the current project.

The Save button saves the edited information and takes the user back to her list of owned archives.
The Cancel button takes her back without saving the changes.



Chapter 6

Collection Service

The Collection Service (CS) manages and stores collections, and it is responsible for the dissemi-
nation of information about them.

The collection principle is a mechanism for dynamically structuring the overall information space
into meaningful (from some community’s perspective) collections.

The graphical user interface of the CS is organized into two areas, the menu area and the working
area as shown in figure 6.1. Menu area contains a menu bar (at the upper) and an action menu.
Working area contains a collection hierarchy area and a collection data area.

Figure 6.1: CS Graphical User Interface

22
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6.1 The menu bar

At the upper of the interface (under the Collection Management title bar) there is a menu bar
with three menus and/or action shortcut.

Via the Browse menu the user may choice the set of collections shown in the working area among
own created collections and all Cyclades collections.

Via the Personal Collections Set shortcut the user can browse/edit his “personal collection set”.
Figure 6.2 shows the GUI that allows user to manage his personal collection set. This GUI has a
working area little bit different from the previous, there are two collections hierarchy areas, one (the
left) for the “actual” personal collections set and the other (the right) for all collections. Clicking
on a collection in the left area the user can remove this from the actual personal collections set,
clicking on a collection in the right area the user can add this from the actual personal collections
set. Collection data area in the middle shows collection data (e.g. name, description) for the
selected collection.

Figure 6.2: CS Graphical User Interface for select the Personal Collections Set

Via Collection→New the user can create a new collection.

6.2 The action menus

Under the menu bar the CS interface provide an action menu. The items of this menu are related
to the collection shown in the collection data area.

If the collection data area shows a collection created by the user than the action menu contains
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the item Edit, in order to edit this collection, and Delete in order to delete this collection.

6.3 The collections hierarchy area

On the left of the working area there is the collections hierarchy area. In this area there is a
navigable hierarchical view of the set of collections actually in use (own created collections or all
collections).

Clicking on a collection allows a user to see collection data in the collection data area and, if the
user has the rights, to manage them (via the action menu).

6.4 The collection data area

On the right of the working area there is the collection data area. This area shows collection data
(e.g. name, description) for the selected collection in the collections hierarchy area.



Chapter 7

Other Services

7.1 Filtering and Recommendation Service

The functionality of the Filtering and Recommendation Services (FRS) is accessed from the graph-
ical user interfaces of the Collaborative Work Service (CWS, chapter 3) and the Search and Browse
Service (SBS, chapter 4). The FRS does not have any graphical interface of its own.

7.2 Rating Management Service

The Rating Management Services (RMS) is a component of the Collaborative Work Services
(CWS). Its functionality is accessed via the CWS user interface (chapter 3). The RMS does
not have any graphical user interfaces of its own.
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